Bonjour à tous, aujourd’hui nous faisons un « throwback » sur les fondamentaux en matière de conception réseau. Cet article est destiné à rafraichir la mémoire de certain, ou d’apprendre une nouvelle notion importante à ceux qui débute !

Nous allons voir comment mettre en place un réseau simple sur cisco packet tracer. Il sera composé de 4 sous-réseaux répartit dans 4 VLAN , et d’un réseau inter-routeur.

Afin de vous faciliter le travail, voici un lien vous permettant de télécharger un fichier .zip contenant le projet cisco packet tracer « de base » sans la configuration ainsi que le fichier avec la configuration achevée et fonctionnelle pour la correction : https://le-guide-du-sysops.fr/wp-content/uploads/2020/12/routage-intervlan-2-pkt-demo-lgds.zip

Nous allons configurer ce réseau « pas à pas » depuis les VLANS 10 et 20 à gauche, vers les VLANS 30 et 40 à droite en travaillant sur la couche 2, puis sur la couche 3 du modèle OSI sur chaque portion de réseau

Configuration sur le switch 1 (gauche)

Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20 
Switch(config-vlan)#exit
Switch(config)#
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 10 
Switch(config-if)#int f0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#

Vu que nous sommes en présence que d’un seul lien montant du switch vers le routeur, nous devons créer un lien 802.1q, qui permet d’encapsuler le label du VLAN dans le paquet réseau.

Switch(config)#int fa0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 10,20
# bonne pratique : permet d'autoriser que les VLANS 10,20 sur le switch 

Configuration du routeur 1 – passerelle des deux réseaux physiquement connectée à lui

Comme notre routeur contient deux interfaces physique, nous devons créer deux interfaces virtuelle afin de pouvoir adresser les deux passerelles de chaque réseau. 10 et 20 corresponde au numéro de VLAN.

Router(config)#int gig7/0.10 # création de la 1er int virtuelle 
Router(config-subif)#encapsulation dot1Q 10 # tj avant l'@ passerelle
 
Router(config-subif)#ip address 192.168.10.254 255.255.255.0
Router(config-subif)#int gig7/0.20 # création de la 2nd int virtuelle
Router(config-subif)#encapsulation dot1Q 20 # tj avant l'@ passerelle
Router(config-subif)#ip address 192.168.20.254 255.255.255.0
Ping depuis PC1 vers sa passerelle

Configuration du switch 2 (droite)

Switch(config)#vlan 30
Switch(config-vlan)#exit
Switch(config)#vlan 40 
Switch(config-vlan)#exit
Switch(config)#
Switch(config)#int f0/3
Switch(config-if)#switchport access vlan 30 
Switch(config-if)#int f0/4
Switch(config-if)#switchport access vlan 40
Switch(config-if)#
Switch(config)#int fa0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 30,40
# bonne pratique permet d'autoriser que les VLANS 30,40 sur le switch

Configuration du routeur 2 – passerelles des deux réseaux physiquement connectés à lui

Router(config)#int gig7/0.30
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 192.168.30.254 255.255.255.0
Router(config-subif)#int gig7/0.40
Router(config-subif)#encapsulation dot1Q 40
Router(config-subif)#ip address 192.168.40.254 255.255.255.0
Ping depuis PC3 vers sa passerelle

Configuration de l’interface inter routeur 1

Router(config)#int gig8/0
Router(config-if)#ip address 10.0.0.1 255.255.255.252
Ping depuis PC1 vers l’interface « sortante » 10.0.0.1 de son routeur

Configuration de l’interface inter routeur 2

Router(config)#int gig8/0
Router(config-if)#ip address 10.0.0.2 255.255.255.252
Ping depuis PC1 vers l’interface « sortante » 10.0.0.1 de son routeur

Routes statiques pour que l’ensemble des réseaux puissent communiquer :

Routeur 1

Router(config)#ip route 192.168.30.0 255.255.255.0 10.0.0.2
Router(config)#ip route 192.168.40.0 255.255.255.0 10.0.0.2

Routeur 2

Router(config)#ip route 192.168.10.0 255.255.255.0 10.0.0.1
Router(config)#ip route 192.168.20.0 255.255.255.0 10.0.0.1
Test de ping depuis PC1 vers les PC des réseaux des VLAN 30 et 40 (192.168.30.1, 192.168.40.1).
Test de ping depuis PC4 vers les PC des réseaux des VLAN 10 et 20 (192.168.10.1, 192.168.20.1)

++

Geoffrey pour Le guide du sysops

Catégories : CiscoNetworks

0 commentaire

Laisser un commentaire